OpenJUMP Tutorial

GISWiki - Das freie Portal für Geoinformatik (GIS)
Wechseln zu: Navigation, Suche

OpenJUMP Tutorial (Grundlagen)

OpenJUMP Tutorial odt m443a6685.jpg


Source(s): OpenJUMP Tutorial


Version 3/2006
Uwe Dalluege
HCU Hamburg
Dept. Geomatik
Autor:
Dipl.-Ing. Uwe Dalluege
HafenCity Universität Hamburg
Department Geomatik
Hebebrandstr. 1
22297 Hamburg
E-Mail: uwe.dalluege@hcu-hamburg.de


Nutzungsbedingungen:
Dieser Text ist urheberrechtlich geschützt und wird unter der GNU Free Documentation License freigegeben
(http://www.gnu.org/licenses/fdl.txt).


Unter Mitarbeit von (in alphabetischer Reihenfolge):
Dipl.-Ing. Jürgen Faber, HCU Hamburg
Dipl.-Ing. Stefan Steiniger, Universität Zürich
Dipl.-Ing. Kay Zobel, HCU Hamburg


Source(s): OpenJUMP Tutorial


Inhaltsverzeichnis

Testdaten

In GeoCity - OpenJUMP Tutorial Testdaten.zip sind alle JUMP-Dateien (jml) für das OpenJUMP Tutorial vorhanden.


Source(s): OpenJUMP Tutorial


Vor dem großen Sprung

OpenJUMP ist ein Geografisches Informationssystem, das ursprünglich von den kanadischen Firmen

Vivid Solutions und Refractions Research unter dem Namen JUMP entwickelt wurde. Der Name JUMP ist die Abkürzung für Unified Mapping Platform, das „J“ deutet auf die zugrunde liegende Programmiersprache „Java“ hin. Das „Open“ steht für „Open Source“ (Quelloffen), was bedeutet, dass der Quellcode des Programms jedermann zugänglich ist. OpenJUMP unterliegt der GNU General Public License und wird heute von Programmierern weltweit gepflegt und weiterentwickelt.

Die besonderen Merkmale von OpenJUMP sind:

GeoCity in OpenJUMP


Source(s): OpenJUMP Tutorial


Die Anzeige-Komponenten von OpenJUMP

Nach dem Start von OpenJUMP erscheint die OpenJUMP Workbench mit einem leeren Projektfenster. Das Projektfenster ist aufgeteilt in eine Layer-Übersicht (Layer List) und ein grafisches Fenster (Layer View), indem die Layer dargestellt werden. Layer sind Ebenen zur Darstellung von geografischen Objekten (Features). Ein Layer stellt im Allgemeinen ein spezielles geografisches Thema dar (z.B. Gewässer, Wälder, Häuser, Böden). Ein Projekt ist die Zusammenfassung aller Layer.

Nach dem Start von OpenJUMP

Es können mehrere Projektfenster geöffnet sein. Über den Menüpunkt „Window“ kann zwischen den einzelnen Fenstern gewechselt werden. Ein neues Projekt wird über „File>NewProject...“ erstellt. Ein bestehendes Projekt wird über „File>OpenProject...“ geöffnet.

Achtung: Jeder Layer muss in einer Datei oder Datenbank gesichert werden, erst dann kann das Projekt gesichert werden (sieheLayer).


Source(s): OpenJUMP Tutorial


Die Werkzeugleiste

Über die [Werkzeugleiste (Tool Bar) können Funktionen wie Zoom, Pan oder der Grafische Editor angesprochen werden.

Werkzeugleiste (Tool Bar)
OpenJUMP Tutorial odt 4caeacc7.jpg Zoom OpenJUMP Tutorial odt 165df2fd.jpg Pan OpenJUMP Tutorial odt 72d61b90.jpg Gesamtansicht
OpenJUMP Tutorial odt 57237d10.jpg Zoom auf markierte Items OpenJUMP Tutorial odt m69d39b1a.jpg Zoom auf Auswahlrahmen
OpenJUMP Tutorial odt m55b94638.jpg Anzeige zurück OpenJUMP Tutorial odt ab377a1.jpg Anzeige vor OpenJUMP Tutorial odt m7b71d6e1.jpg Layerdarstellung ändern
OpenJUMP Tutorial odt 106743f.jpg Attribute anzeigen und ändern OpenJUMP Tutorial odt m482948d4.jpg Markieren/Auswählen OpenJUMP Tutorial odt 15e5e0b1.jpg Markierung aufheben
OpenJUMP Tutorial odt 1ce89f53.jpg Auswahlrahmen ziehen OpenJUMP Tutorial odt 605723c6.jpg Feature-Informationen OpenJUMP Tutorial odt 307cdfbb.jpg Editor
OpenJUMP Tutorial odt 44555252.jpg Messen OpenJUMP Tutorial odt 23be0811.jpg Rückgängig OpenJUMP Tutorial odt m20f8c28d.jpg Wiederherstellen
OpenJUMP Tutorial odt m7d262e82.jpg Ausgabefenster
OpenJUMP Tutorial odt m1aa90d8c.jpg SchnellZoom


Source(s): OpenJUMP Tutorial


Daten

Ein wesentlicher Bestandteil eines GIS sind die Daten (Geometriedaten und Sachdaten). Die Frage ist, wie wir diese Daten in unser Projekt bekommen.


Source(s): OpenJUMP Tutorial


Geometriedaten

Es gibt verschiedene Methoden, Geometriedaten in ein Projekt zu integrieren:

  1. Durch „freies Zeichnen“ mit dem Grafischen Editor. Dies ist eine sehr einfache Methode und entspricht sicherlich nicht der gängigen Praxis (siehe Der grafische Editor“)
  2. Durch Import von Dateien, die in einem bestimmten Format beschrieben sind. OpenJUMP unterstützt folgende Formate:
    a) Das JUMP GML Format (.jml), welches ein vereinfachtes GML-Format ist.
    b) Das GML 2.0 Format.
    c) Das WKT (Well Known Text) Format.
    d) ESRI Shapefile.
  3. Durch Darstellung von Rasterdaten, die ein WMS-Server liefert. Hier besteht die Möglichkeit auf dem Raster mit dem Grafischen Editor zu digitalisieren.
  4. Durch Laden einer Datenbanktabelle im PostGIS Format (nur mit Hilfe eines PlugIns). Hierbei werden die Daten (Geometrie- und Sachdaten) in der Objektrelationalen Datenbank PostgreSQL mit einer PostGIS Erweiterung abgelegt und können in OpenJUMP dargstellt werden.


Source(s): OpenJUMP Tutorial


Sachdaten (Attributwerte)

Es gibt verschiedene Methoden, Sachdaten in ein Projekt zu integrieren:

  1. Durch direkte Eingabe in OpenJUMP. Hierzu müssen Geometriedaten vorliegen (siehe Schema bearbeiten)
  2. Durch Import von Dateien, die in einem bestimmten Format beschrieben sind. OpenJUMP unterstützt folgende Formate, in dem allerdings auch Geometriedaten enthalten sind:
    a) Das JUMP GML Format (.jml), welches ein einfaches GML-Format ist.
    b) Das GML 2.0 Format.
    c) ESRI Shapefile
  3. Durch Laden einer Datenbanktabelle im PostGIS Format (nur mit Hilfe eines PlugIns).


Source(s): OpenJUMP Tutorial


Der grafische Editor OpenJUMP Tutorial odt m5fa19a26.jpg

OpenJUMP verfügt über einen einfachen grafischen Editor, mit dem man die Geometrien (räumliche Attribute) von geografischen Objekten (Features) eingeben und editieren kann. Es können die Geometrien Punkt (Point), Linienzug (Linestring) und Fläche (Polygon) erstellt und bearbeitet werden.

Der grafische Editor wird mit dem Knopf OpenJUMP Tutorial odt m5fa19a26.jpg (Editing Toolbox) aus der Werkzeugleiste (Tool Bar) aufgerufen.

Features werden auf einem Layer dargestellt, der mit „Layer>Add a new layer“ erzeugt wird. Natürlich kann auch auf bestehenden Layern gezeichnet werden, wenn sie editierbar (editable) sind.


Source(s): OpenJUMP Tutorial


Layer>Add a new layer

Der neue Layer erhält den Namen „New“ und ist editierbar (editable). Ist ein Layer editierbar, so wird der Layername rot dargestellt. Wird ein editierbarer Layer mit Links-Klick markiert, erscheint der Name gelb und man kann auf ihm zeichnen oder bestehende Geometrien verändern. Mit dem Menüpunkt „Editable“ (Rechtsklick auf den Layernamen) kann der Editierstatus eines Layers geändert werden. Durch Links-Doppelklick auf den Layernamen kann dieser umbenannt werden.


Source(s): OpenJUMP Tutorial


Editing Toolbox

Die Editing Toolbox stellt Werkzeuge zur Bearbeitung von Geometrien zur Verfügung:

Editing Toolbox

OpenJUMP Tutorial odt m4bb0d739.gif
OpenJUMP Tutorial odt m60747d48.gif
OpenJUMP Tutorial odt m75123cc0.gif
OpenJUMP Tutorial odt 65dcb836.gif


Source(s): OpenJUMP Tutorial


Optionen (Snap/Grid)

Unter Optionen kann unter anderem der Fangmodus (Snapping) und Gitterlinien (Grid Display) eingestellt werden. Voreingestellt ist ein Fangradius von 10 Pixeln und „Auf Knoten fangen“ (Snap to vertices).


Source(s): OpenJUMP Tutorial


Fang- und Gitteroptionen
Tolerance: Fangradius in Pixel
Snap to vertices: Auf Knoten fangen
Snap to vertices and lines: Auf Knoten oder Linie fangen
Snap to grid: Auf Punkte vom Gitternetz (grid) fangen
Show grid: Gitternetz ein/aus
Size: Gitterabstand in Modelleinheiten
Show grid as dots: Gitternetz als Punkte darstellen
Show grid as lines: Gitternetz als Linien darstellen


Source(s): OpenJUMP Tutorial


Features

Features sind abstrahierte Objekte der realen Welt. Zum Beispiel werden Straßen als Linienzüge, Gebäude als Flächen oder Bäume als Punkte abstrahiert und dargestellt.

In OpenJUMP hat jedes Feature ein räumliches Attribut (Geometrie) und keins oder mehrere nicht-räumliche Attribute (non-spatial attributs, Fachdaten, Sachdaten) z.B. Straßenname, Eigentümer, Baumhöhe.


Source(s): OpenJUMP Tutorial


Features zeichnen

Es können drei verschiedene Features gezeichnet werden:


Source(s): OpenJUMP Tutorial


Punkt (Point), OpenJUMP Tutorial odt 60cdf862.jpg
Linienzug (Linestring) OpenJUMP Tutorial odt m7a6ce38b.jpg
und Fläche (Polygon) OpenJUMP Tutorial odt 3e903415.jpg

Nach Auswahl des Geometrietyps wird mit Linksklick die Grafik gezeichnet. Linienzüge und Flächen werden mit einem Doppel-Linksklick beendet.


Source(s): OpenJUMP Tutorial


Zeichnen einer Fläche (Polygon):

  • Layer markieren und editierbar machen.
  • „Draw Polygon Tool“ drücken OpenJUMP Tutorial odt 53e598aa.jpg
  • Den Anfangspunkt mit Linksklick im Grafikfenster markieren.
  • Weitere Punkte mit Linksklick hinzufügen.
  • Mit Doppel-Linksklick Fläche schließen.


Source(s): OpenJUMP Tutorial


Zeichnen eines „Lochs“ in einer Fläche:

Fläche mit „Loch“
  • Layer markieren und editierbar machen.
  • Fläche mit OpenJUMP Tutorial odt m6a3149c4.jpg selektieren.
  • Fläche bzw. Loch zeichnen.


Source(s): OpenJUMP Tutorial


Mehrere Features zusammenfassen (Geometry Collection)

Es können die Geometrien mehrerer Features zu einer logischen Einheit zusammengefasst werden. Hierbei müssen sich die Features auf einem Layer befinden.
Achtung: Beim Zusammenfassen können nicht-räumliche Attribute der Features verloren gehen.

  • Features, die zusammengefasst werden sollen, mit Shift + OpenJUMP Tutorial odt m4795d0d5.jpg markieren
  • Rechtsklick auf grafisches Fenster
  • Im Kontextmenü: „Combine selected features


Source(s): OpenJUMP Tutorial


Features auflösen

  • Geometry Collection mit OpenJUMP Tutorial odt m4795d0d5.jpg markieren
  • Rechtsklick auf grafisches Fenster
  • Im Kontextmenü „Explode selected features


Source(s): OpenJUMP Tutorial


Features markieren und verschieben

Es stehen drei Markierungswerkzeuge zur Verfügung:

OpenJUMP Tutorial odt m4795d0d5.jpg Ganzes Feature markieren.
OpenJUMP Tutorial odt 5ca253ba.jpg Teil einer Geometry Collection selektieren
OpenJUMP Tutorial odt m26a15633.jpg Ein Loch (hole) markieren
OpenJUMP Tutorial odt 17ba01a6.jpg Feature verschieben


Source(s): OpenJUMP Tutorial


Knoten (vertex, vertices) bearbeiten

OpenJUMP Tutorial odt m1bd45ce0.jpg Knoten (vertex) zu einem Feature hinzufügen
  • Feature markieren
  • Mit Linksklick Knoten auf Liniensegment einfügen


OpenJUMP Tutorial odt m7eee1a61.jpg Knoten löschen
  • Feature(s) markieren
  • Mit Linksklick Knoten löschen


OpenJUMP Tutorial odt m42f07d0a.jpg Knoten verschieben
  • Feature markieren.
  • Mit Linksklick Knoten verschieben.


OpenJUMP Tutorial odt 23a9981b.jpg Knoten zusammenfassen
  • Ersten Knoten mit Linksdruck anwählen und auf zweiten Knoten ziehen


OpenJUMP Tutorial odt m3d5cf1ee.jpg Zwei markierte Knoten zusammenfassen
  • Feature markieren (Funktion arbeitet nur mit einem Feature!)
  • Werkzeug wählen und mit Linksdruck Rahmen um beide Knoten ziehen
  • Shift-Taste drücken und auf den Zielknoten innerhalb des Rahmens klicken


Source(s): OpenJUMP Tutorial


Linienzug (Linestring) teilen

OpenJUMP Tutorial odt 21e9571f.jpg Linienzug teilen
  • Feature markieren
  • Mit Linksklick Linienzug teilen


OpenJUMP Tutorial odt 717b0761.jpg Linienzüge die sich schneiden an Schnittpunkt teilen
  • Beide Linienzüge markieren
  • Mit Linksklick auf Schnittpunkt klicken


Source(s): OpenJUMP Tutorial


Layerbearbeitung

Layer

Layer sind Ebenen zur Darstellung von Features (collection of features) oder Rasterdaten. Die linke Seite des Projekt-Fensters zeigt eine Übersicht aller vorhandenen Layer im Projekt. Layer können unter Kategorien (hier „Working“ und „System“) zusammengefasst werden. Durch geschickte Auswahl von Layernamen kann schon ein einfaches Informationssystem erstellt werden. In unterem Beispiel werden von GeoCity der Teich, die Straßen, die Flurstücke und die Beschriftung „GeoCity“ angezeigt. Alle anderen Layer sind ausgeschaltet.


Source(s): OpenJUMP Tutorial


Übersicht über Straßen, Flurstücke und Teich in GeoCity


Source(s): OpenJUMP Tutorial


Layereigenschaften

Layer ...

  • ... haben einen Namen
  • ... können kopiert, ausgeschnitten, gelöscht, eingefügt und in der Hierarchie verschoben werden
  • ... können zu Kategorien (category) zusammengefasst werden
  • ... können Vektor- und Raster-Daten darstellen
  • ... müssen in einer Datei oder Datenbank gesichert werden
  • ... haben eine farbliche Darstellung (siehe Rendering)
  • ... können in Abhängigkeit von Feature-Attributen verschiedenartig dargestellt werden
    (siehe Thematische Darstellung, Beschriftung)
  • ... haben ein Attributschema (siehe Schema bearbeiten und Attribute bearbeiten)

Unter dem Menüpunkt „Layer“ können Layer, WMS-Layer (sieheWMS-Layer) und Layer-Kategorien erstellt werden.


Source(s): OpenJUMP Tutorial


Über Menü Layer verwalten
OpenJUMP Tutorial odt m70cba6d5.gif
OpenJUMP Tutorial odt m2dca38f5.gif
OpenJUMP Tutorial odt m2b534bbf.gif
OpenJUMP Tutorial odt 34321c07.gif
OpenJUMP Tutorial odt 5599c3f1.gif
OpenJUMP Tutorial odt 9e11a16.gif
OpenJUMP Tutorial odt m49244e85.gif
OpenJUMP Tutorial odt m16bf4ec2.gif
OpenJUMP Tutorial odt m6d02659a.gif


Source(s): OpenJUMP Tutorial


Mit Rechtsklick auf den Layernamen können spezielle Layereigenschaften bearbeitet werden.

Rechtsklick auf Layername
Editable: Um einen Layer bearbeiten zu können, muss er editierbar sein!
Zoom to layer: Den gesamten Layer anzeigen
Change styles... : Layerdarstellung ändern)
View / Edit Attributes: Layerattribut ansehen oder ändern
View / Edit Schema: Schema für Attribute ansehen oder ändern
Save Dataset As File... : Layer in Datei speichern
Move Layer Up: Layer nach oben verschieben. Höhere Priorität für Darstellung
Move Layer Down: Layer nach unten verschieben. Niedrigere Priorität für Darstellung
Cut selected layers: Markierte Layer ausschneiden
Copy selected layers: Markierte Layer kopieren
Remove selected layers: Markierte Layer löschen
Add new features...: Features im Well-Known Textformat hinzufügen
Paste items: Kopierte Items einfügen
Delete all features: Alle Features auf Layer löschen
Select Current Layer Items: Alle Items markieren
Change SRID...: SRID-Information für Layer ändern (nur bei PostGIS-Datenbankanbindung)


Source(s): OpenJUMP Tutorial


Layer und Projekt sichern und laden

Jeder editierte Layer muss einzeln gesichert werden! Es stehen verschiedene Formate zur Verfügung, wobei wir hier nur das „JUMP GML“ und das „PostGIS“ Format verwenden wollen.

Mit „Save Dataset As File...:“ kann der Layer in einer Datei gesichert werden.

Der Menüpunkt „File>Save dataset as...“ bietet auch die Möglichkeit den Layer in einer Datenbank zu sichern (siehe Tabelle schreiben). Sind alle editierten Layer gesichert, kann das Projekt mit „File>Save Project“ gespeichert werden.


Source(s): OpenJUMP Tutorial


WMS-Layer

Die von einem WMS-Server (Web Map Service) zur Verfügung gestellten Daten können in OpenJUMP auf einem Layer dargestellt werden. Dieser Layer dient nur zur Darstellung der WMS-Daten und hat nicht die Eigenschaften eines „normalen“ Layers. Es kann z.B. auf diesem Layer nicht gezeichnet werden. Dieser Layer kann aber als Grundlage zur Erweiterung des Informationssystems dienen, indem man z.B. durch Vektorisierung neue Geometrien erzeugt und mit Attributen verknüpft. Über „Layer>Add a WMS query“ wird die URL (Uniform Resource Locator) des WMS-Servers eingegeben. Der WMS-Server kann verschiedene WMS-Layer anbieten, die man mit dem Knopf „Choose Layers“ auswählen kann.
'Achtung: Möchte man die WMS-Layer auch in OpenJUMP auf verschiedenen Layern darstellen, muss man diesen Vorgang („Layer>Add a WMS query“)'für jeden WMS-Layer wiederholen!


Source(s): OpenJUMP Tutorial


URL des WMS-Servers eingeben
WMS-Layer wählen

Der WMS-Server kann die Rasterdaten in unterschiedlichen Koordinaten-Referenzsystemen (Coordinate Reference System; CRS) schicken. Für die Darstellung muss ein entsprechendes System gewählt werden. Hierbei werden die Systeme nach der EPSG-Notation angegeben (European Petroleum Survey Group).

Koordinaten-Referenzsystem wählen

Mit „Finish“ wird die Auswahl beendet. Es kann allerdings passieren, dass das Grafikfenster leer bleibt. Mit „View>Zoom to WMS layer“ kann dann auf einen markierten Layer gezoomt werden. Je nach Auslastung des WMS-Servers kann es einige Sekunden dauern, bis das Bild aufgebaut wird.

In unserem Beispiel sind zwei Layer vorhanden, auf denen die Grafiken der WMS-Layer dargestellt werden. Mit Rechtsklick auf einen Layer kann dann mit „Zoom to WMS layer“ auf die Gesamtansicht, oder besser die Bounding Box des WMS-Layers, gezoomt werden. Eine Bounding Box definiert einen Rahmen für einen WMS-Layer.

Die Flüsse Europas
OpenJUMP Tutorial odt 5bad5360.jpg


Liegen verschiedene WMS-Layer auf einem OpenJUMP-Layer, kann mit „Zoom to WMS layer“ auf die entsprechende Bounding Box des WMS-Layers gezoomt werden. Außerdem kann man mit dem OpenJUMP Tutorial odt me73987b.jpg Knopf verschiedene Informationen über die gesendeten Daten des WMS-Servers bekommen. In der unteren Tabelle sehen wir z.B. den Titel, den Namen, das SRS (Spatial Reference System; Räumliches Bezugssystem) und die Ausdehnungen der zugehörigen Bounding Boxen.

Informationen über die WMS-Layer des WMS-Servers


Source(s): OpenJUMP Tutorial


Schema bearbeiten

Für jeden Layer kann ein sogenanntes Schema erstellt werden. Hiermit werden die nicht-räumlichen Attribute (non-spatial attributes) der Features definiert.
Beispiel: Auf einem Layer werden Flurstücke dargestellt. Möchte man die Namen der Eigentümer, den Wert oder z.B. die Fläche der Flurstücke erfassen, so muss man die Attribute zuvor in einem Schema vereinbaren.

Dieses Schema gilt dann für alle Features auf dem Layer. Daher ist es bei der Modellierung eines GIS wichtig, die Layer bzw. deren Schema so zu definieren, dass gleichartige Objekte in einem Layer erfasst werden können. Es ist nicht sinnvoll, z.B. Flurstücke und Bäume auf einem Layer zu erfassen, weil Flurstücke und Bäume unterschiedliche Attribute haben. Wie wir später sehen werden, können wir den Begriff Schema gleich dem Begriff Relation-Schema einer relationalen Datenbank setzen.

Jedem Attribut, auch Feld (Field) genannt, wird ein bestimmter Datentyp (Data Type) zugeordnet, wobei OpenJUMP den Datentyp Integer (ganze Zahl), Double (Dezimalzahl), String (Text), Date (Datum) und Geometry kennt.
Achtung: Der Datentyp „Object“ wird hier nicht verwendet!

Mit Rechtsklick auf den Layernamen erscheint ein Pulldown-Menü mit OpenJUMP Tutorial odt cd759c1.jpg, mit dem man das Schema bearbeiten kann. Hiefür muss der Layer editierbar sein!

OpenJUMP Tutorial odt m4133328f.gif
OpenJUMP Tutorial odt bf3eae0.gif
OpenJUMP Tutorial odt 50eebc00.gif
OpenJUMP Tutorial odt 5efa5f6f.gif
Schema für den Layer „flurstuecke“ mit den Attributen GEOMETRY, vorname, nachname, flaeche


Source(s): OpenJUMP Tutorial


Attribute bearbeiten

Wurde ein Schema für einen Layer erstellt, können die Attribute der Features eingegeben werden. Mit Rechtsklick auf den Layernamen erscheint ein Pulldown-Menü mit OpenJUMP Tutorial odt m6c165dbd.jpg, mit dem man die Attribute bearbeiten kann. Der Layer muss zur Bearbeitung der Attributwerte editierbar sein! Die Betrachtung ist aber immer möglich.
Die Werkzeugleiste des Attribut-Fensters bietet Funktionen zum Zoomen und Identifizieren von Features, deren Zeilen in der Tabelle markierten wurden. Möchte man z.B. wissen, welches Flurstück Otto Fant gehört, markiert man einfach die Zeile von Otto. Durch Linksklick auf die Lupe OpenJUMP Tutorial odt 6f83a3ed.jpg wird auf das Flurstück gezoomt und mit einem weiteren Linksklick auf die Taschenlampe OpenJUMP Tutorial odt 3d005fe1.jpg kurzzeitig hervorgehoben.

Um die Funktionen der Werkzeugleiste nutzen zu können, muss eine oder mehrere Zeilen in der Tabelle markiert sein.


Source(s): OpenJUMP Tutorial


OpenJUMP Tutorial odt 156290cc.gif

OpenJUMP Tutorial odt mf65eb02.gif
OpenJUMP Tutorial odt 7bc0addd.gif
OpenJUMP Tutorial odt 658830ea.gif
OpenJUMP Tutorial odt m460f58c1.gif
OpenJUMP Tutorial odt m50226778.gif
Attributtabelle des Layers „flurstuecke“
Geometriedaten im Well-Known Textformat (WKT)

Die Geometriedaten der markierten Zeile kann man sich mit dem Info-Knopf OpenJUMP Tutorial odt 605723c6.jpg der Attributtabelle anzeigen lassen. Man kann zwischen den Formaten WKT (Well Known Text), GML (Geography Markup Language) und dem CL-Format (Koordinatenliste) wählen.


Source(s): OpenJUMP Tutorial


Layerdarstellung (Styles) OpenJUMP Tutorial odt m7b71d6e1.jpg

Die Darstellung eines Layers, und somit der Features auf diesem Layer, kann über das „Change Styles“ Fenster verändert werden, das über den Knopf OpenJUMP Tutorial odt m7b71d6e1.jpg aktiviert wird. Hierfür muss der Layer nicht editierbar sein. Es gibt vier Möglichkeiten zur Bearbeitung: Rendering (Allgemeine Darstellung), Color Theming (Thematische Darstellung), Labels (Beschriftung) und Decorations (Anfangs-/Endpunkt Darstellung).


Source(s): OpenJUMP Tutorial


Allgemeine Darstellung (Rendering)

Unter dem Reiter „Rendering“ kann Folgendes eingestellt werden:

  • die Farbe der Linien und Flächen
  • das Füllmuster von Flächen (Fill pattern)
  • die Strichlierung der Linien (Line pattern)
  • die Linienbreite (Line width)
  • die Transparenz der Farben (Transparency)
  • die Größe der Knoten (Vertices Size)
Allgemeine Darstellung eines Layers ändern


Source(s): OpenJUMP Tutorial


Thematische Darstellung (Color Theming)

Will man eine thematische Karte erstellen, müssen vorher Attribute für die Features des Layers zur Verfügung stehen (siehe Schema und Attribute bearbeiten). In diesem Beispiel haben die Features des Layers „landwirtflaechen“ das Attribut „nutzungsart“ mit den Attributwerten Acker, Getreide, Grünland, Hof und Wald. Das Farbschema kann allgemein mit „Colour Scheme“ oder durch Linksklick auf die Attributfarbe eingestellt werden.

OpenJUMP Tutorial odt m5517e715.jpg

OpenJUMP Tutorial odt 7c43c1fe.jpg

Thematische Darstellung von Nutzungsarten mit Beschriftung (Label)

Bestehen die Attributwerte aus numerischen Daten (Integer, Double) und möchte man Intervalle thematisch darstellen, so muss in dem Kästchen „by range“ ein Haken gesetzt werden. In Abhängigkeit von „Range count“ werden dann Intervalle berechnet und farblich dargestellt. In diesem Beispiel gibt es zu jeder landwirtschaftlichen Fläche einen Ertrag in Euro pro Hektar (ertrag E/Ha). Da „Range count“ auf 6 eingestellt ist, ergeben sich sechs Intervalle, die farblich dargestellt werden.

OpenJUMP Tutorial odt 7b74f2f.jpg
Thematische Darstellung von Ertrag pro Hektar mit Beschriftung (Label)


Source(s): OpenJUMP Tutorial


Beschriftung (Labels)

Beschriftung von Straßen mit Hilfe von Labels I
Beschriftung von Straßen mit Hilfe von Labels II
Beschriftung von Straßen mit Hilfe von Labels III

Die Attributwerte der Features können als Beschriftung dargestellt werden. In unserem Beispiel werden die Straßen des Layers „strassen“ mit dem Attribut „name“ beschriftet. In dem Fenster unter dem Reiter „Labels“ muss ein Haken vor „Enable labelling“ gesetzt werden und hinter „Label attribute“ der Attributname ausgewählt werden. Außerdem kann die vertikale Ausrichtung für Linien(Vertical alignment (for lines)), der Drehwinkel (Angle attribut) und die Schrifthöhe (Height attribut) in Abhängigkeit von Attributwerten eingestellt werden. Die direkte Schrifthöhe kann hinter „Height“ eingestellt werden. Wird „Scale labels with the zoom level“ gewählt, verändert sich die Schrifthöhe in Abhängigkeit des Zoomfaktors.

Mit „Hide overlapping labels“ werden sich überdeckende Texte ausgeblendet. Mit „Change Colour...“ und „Change Font...“ kann die Schriftfarbe und der Font verändert werden. Die Positionierung der Texte übernimmt das Programm und ist nicht beeinflussbar!


Source(s): OpenJUMP Tutorial


Anfangs- Endpunkt Darstellung (Dekorations)

Mit Hilfe von „Dekorations“ kann ein Anfangs- und Endsymbol einer Linie festgelegt werden. Die ausgewählten Symbole müssen vom linken Teilfenster ins rechte Teilfenster übertragen werden, um zur Anwendung zu kommen.

Linie mit „Start-Arrow-Solid“ kombiniert mit einer Beschriftung (Label) I
Linie mit „Start-Arrow-Solid“ kombiniert mit einer Beschriftung (Label) II


Source(s): OpenJUMP Tutorial


Analysen

OpenJUMP verfügt über eine Vielzahl von räumlichen Analysemöglichkeiten, die über „Tools>Analysis“ aufgerufen werden können:


Source(s): OpenJUMP Tutorial


Buffer

Die verbreiterte Hafenstraße I
Die verbreiterte Hafenstraße II
Die verbreiterte Hafenstraße III

Mit Hilfe der Buffer-Funktion kann man einen Saum um eine Geometrie legen. Es entsteht eine neue Fläche, die auf einem neuen Layer abgelegt wird. Dieser neue Layer wird automatisch erzeugt. Bei einem Punkt entsteht z.B. nach dem „Buffern“ eine Kreisfläche um den Punkt. Ein Linienzug wird um einen zu bestimmenden Abstand verbreitert und nun als neue Fläche dargestellt. Die ursprüngliche Geometrie wird nicht verändert! Die Buffer-Funktion bezieht sich in OpenJUMP immer auf alle Geometrien, die auf dem Layer liegen.

Die neue(n) Fläche(n) kann man für weitere Analysen nutzen. In unserem Beispiel wollen wir die Hafenstraße auf 20m verbreitern. Dazu legen wir einen Buffer im Abstand von 10 um den Linienzug der Straße. Es entsteht ein neuer Layer (Buffer-Hafenstrasse), auf dem die verbreiterte Hafenstraße dargestellt wird.


Source(s): OpenJUMP Tutorial


Overlay

Beschreibung

Mit der Funktion Overlay können wir die Schnittmenge zweier (oder mehrerer) Flächen bestimmen. Wir können jetzt in unserem Beispiel „Hafenstraßenverbreiterung“ (siehe Buffer) die Buffer-Fläche mit den Flurstücken verschneiden. Die Schnittmenge wird auf einen neuen Layer gelegt und zeigt uns die Teile der Flurstücke, die für die Erweiterung benötigt werden. Mit dem View/Edit Attributes Knopf kann man dann z.B. alle Eigentümer sehen, die von der Baumaßnahme betroffen sind.


Source(s): OpenJUMP Tutorial


Schnittmenge aus „flurstuecke“ und „Buffer-HafenStrasse“ I
Schnittmenge aus „flurstuecke“ und „Buffer-HafenStrasse“ II
Betroffene Eigentümer


Source(s): OpenJUMP Tutorial


Union

Mit Union werden Flächen auf einem Layer zu einer neuen Fläche zusammengefasst (vereinigt). Die neue Fläche wird auf einem neuen Layer dargestellt. In unserem Beispiel „Hafenstraßenverbreiterung“ möchten wir für eine Kostenkalkulation die Gesamtfläche aller Teilflächen berechnen, die auf dem Layer „Overlay“ liegen, also von unseren betroffenen Flurstücken. Hierzu wenden wir die Funktion „Union“ auf den Layer “Overlay“ an. Ein neuer Layer „Union“ wird erstellt, bei dem wir das Schema um das Attribut „flaeche“ erweitern. Mit der Funktion Analysis>Calculate areas and lengths...kann dann die Gesamtfläche berechnet werden. Hierfür muss der Layer editierbar sein.


Source(s): OpenJUMP Tutorial


Zusammengefasste Flächen auf dem Layer „Union“ (I)
Zusammengefasste Flächen auf dem Layer „Union“ (II)
Berechnete Gesamtfläche


Source(s): OpenJUMP Tutorial


Geometrische Funktionen

Mit Hilfe der Geometrischen Funktionen („Tools>Analysis>Geometry functions...“) können unter anderem die Funktionen A-B, B-A und die Symmetrische Differenz ausgeführt werden. Diese Funktionen beziehen sich auf zwei Layer mit jeweils einem Feature.

Bei der Differenz A-B wird von der Fläche A die Fläche B „herausgeschnitten“ und eine neue Fläche auf einem neuen Layer gebildet, falls sich die Flächen überschneiden (gilt sinngemäß auch für B-A). Bei der Symmetrischen Differenz wird die Fläche auf Layer A mit der Fläche auf Layer B zusammengefasst (Union) und die überlappende Fläche herausgeschnitten. Auch hier wird eine neue Fläche auf einem neuen Layer erzeugt.

In unserem Beispiel hat Radio-GeoCity zwei neue Sendemasten bekommen (FunkMast-A und FunkMast-B). Bei der Überlagerung der Funkwellen entstehen Interferenzen, die zu Störungen des Empfangs führen könnten. Wir möchten folgendes herausfinden:

  1. Welches Gebiet wird durch Mast-A störungsfrei abgedeckt?
  2. Welches Gebiet wird durch Mast-B störungsfrei abgedeckt?
  3. Welches Gebiet hat guten Empfang?


Source(s): OpenJUMP Tutorial


Radio-GeoCity mit zwei neuen Funkmasten

Die erste Frage können wir dadurch beantworten, dass wir die Differenz A-B mit den Layern Buffer-FunkA und Buffer-FunkB bilden. Die zweite Frage wird durch die Bildung der Differenz B-A beantwortet.

Störungsfreier Empfang durch Mast-A (rot; Differenz A-B) (I)
Störungsfreier Empfang durch Mast-A (rot; Differenz A-B) (II)

Die dritte Frage können wir dadurch beantworten, dass wird die Symmetrische Differenz zwischen
Buffer-FunkA und Buffer-FunkB bilden. Leider müssen wir feststellen, dass die Anwohner im Wohngebiet um die Hafenstraße möglicherweise schlechten Empfang haben. Mit OpenJUMP wäre das nicht passiert :-)

Guter Empfang (blau; Symmetrische Differenz) (I)
Guter Empfang (blau; Symmetrische Differenz) (II)

Anbindung an eine PostgreSQL/PostGIS Datenbank

Mit einem PlugIn kann OpenJUMP Tabellen (Relationen) einer PostgreSQL/PostGIS Datenbank verarbeiten. PostgreSQL ist ein Objekrelationales Datenbankverwaltungssystem (ORDBMS), zu dem es eine sogenannte PostGIS-Erweiterung gibt. Mit Hilfe dieser Erweiterung können Geometrien und Attributwerte in normalen Relationen gespeichert und verarbeitet werden.

Um in OpenJUMP mit PostGIS arbeiten zu können, benötigen wir einen JDBC-Treiber (Java DataBase Connectivity) für PostgreSQL und zwei OpenJUMP PlugIns. Den neusten JDBC-PostgreSQL-Treiber erhalten wir von der PostgreSQL-Homepage http://www.postgresql.org/ (z.B. postgresql-8.0.309.jdc3.jar). Der Treiber muss in das ...\lib\ext Verzeichnis der Java Runtime Environment kopiert werden (z.B. C:\Programme\Java\jre1.5.0_04\lib\ext).

Die beiden OpenJUMP PlugIns JumpPostGISrzcn.jar und sridsupport.jar müssen wir in das Verzeichnis ...\lib\ext (liegt im Installationsverzeichnis von OpenJUMP, z.B. C:\Programme\OpenJUMP\lib\ext) kopieren. Das PlugIn JumpPostGISrzcn.jar sorgt für die Verbindung zum Datenbankserver und für das Lesen und Speichern der Daten. Mit dem PlugIn sridsupport.jar kann man einem Layer eine Kennung für das Räumliche Bezugssystem zuordnen (Spatial Reference System Indentifier, SRID). Um eine Verbindung mit einem PostgreSQL/PostGIS Server aufnehmen zu können, benötigt man verschiedene Informationen:

  • die IP-Adresse des PostgreSQL-Servers
  • die Portnummer (normalerweise 5432)
  • den Datenbanknamen
  • den Tabellennamen
  • den Benutzernamen und das Passwort


Source(s): OpenJUMP Tutorial


1Tabelle lesen

Liegt bereits eine Tabelle im PostGIS-Format vor, kann man sie mit „File>Load Dataset(s)...“ laden.

PostGIS Tabelle lesen

Dazu muss hinter „Format:“ PostGIS Table eingestellt werden. Die Tabelle wird dann in OpenJUMP auf einem Layer dargestellt, der den Namen der Tabelle hat.


Source(s): OpenJUMP Tutorial


Tabelle schreiben

Mit „File>Save dataset as...“ kann ein markierter Layer in die Datenbank geschrieben werden. Die Features auf dem Layer müssen ein Attribut für einen eindeutigen Schlüssel besitzen (Primärschlüssel), damit die Datensätze zugeordnet werden können. Dieses Attribut wird hinter „Unique Column:“ eingegeben. Ist die Tabelle noch nicht vorhanden, so wird sie neu angelegt. Jeder Tabelle in PostGIS ist ein SRID-Wert (Spatial Reference System Identifier) zugewiesen. Es können nur Datensätze in die Tabelle geschrieben werden, die das gleiche Bezugssystem haben. Mit „Layer>Change SRID...“ kann man einem markierten Layer einen SRID-Wert zuweisen, wenn das entsprechende PlugIn geladen ist (siehe oben).


Achtung: Es werden nur bestehende Datensätze verändert oder neue hinzugefügt! Löscht man aber Features auf einem Layer, so werden diese Datensätze nicht beim Schreiben in die Datenbank gelöscht!

Man muss dann entweder den Layer unter einem neuen Tabellennamen abspeichern oder die Tabelle vorher in PostgreSQL löschen (was leider etwas umständlich ist).

PostGIS Tabelle schreiben


Source(s): OpenJUMP Tutorial


Drucken

In OpenJUMP ist es nicht möglich, die dargestellte Grafik direkt zu drucken. Die Grafik kann aber im Raster- (PNG, JPEG) oder Vektor-Format (Scalable Vector Graphics, SVG) in eine Datei gespeichert - und mit einem geeigneten Programm (z.B. PhotoFiltre bzw. Inkscape) ausgedruckt werden. Hierbei ist das Vektorformat SVG dem Rasterformat vorzuziehen, weil es besser skalierbar ist.

Mit „File>Save Image in SVG Format“ wird die Grafik des Projekts im SVG-Format gespeichert. Hierbei werden nur die Layer gespeichert, die auch eingeschaltet sind. Mit dem Open Source Programm Inkscape kann dann z.B. die Datei bearbeitet und gedruckt werden.

GeoCity als Grafik in Inkscape


Source(s): OpenJUMP Tutorial


Literaturverzeichnis

  • Aquino, J., Davis M. (2004): JUMP Workbench User's Guide, Vivid Solutions
  • Aquino, J., Kim D. (2003): JUMP Developer's Guide, Vivid Solutions
  • Bill, R. (1999): Grundlagen der Geo-Informationssysteme, Band 1, Wichmann Verlag
  • Bill, R. (1999): Grundlagen der Geo-Informationssysteme, Band 2, Wichmann Verlag
  • Bill R., Zehner M. L. (2001): Lexikon der Geoinformatik, Wichmann Verlag
  • Eisentraut, P. (2003): PostgreSQL Das Offizielle Handbuch, mitp-Verlag Bonn
  • Lake, R., Burggraf D. S.,Trninic M., Rae L. (2004): Geography Mark-Up Language (GML), John Wiley & Sons, Ltd
  • Lange, N. (2002): Geoinformatik in Theorie und Praxis, Springer-Verlag Berlin Heidelberg New York
  • OGC (2003): OpenGIS Geography Markup Language (GML) Implementation Specification, Open GIS Consortium
  • OGC (2001): OpenGIS Implementation Specification: Coordinate Transformation Services, Open GIS Consortium
  • OGC (1999): OpenGIS Simple Features Specification For SQL Revision 1.1, Open GIS Consortium
  • OGC (2004): Web Map Service (WMS), Version: 1.3, Open GIS Consortium
  • Refractions Research (2005): PostGIS Manual
  • RRZN (2004): SQL Grundlagen und Datenbankdesign, Regionales Rechenzentrum / Universität Hannover
  • The PostgreSQL Global Development Group (2005): PostgreSQL 8.1.0 Documentation

Linksammlung

Inkscape http://www.inkscape.org/

JUMP http://www.openjump.org/

Jump Pilot Project http://jump-pilot.sourceforge.net/

MapServer http://www.umn-mapserver.de/

OGP Surveying & Positioning Committee http://www.epsg.org/

Open Geospatial Consortium http://www.opengeospatial.org/

OpenJUMP http://openjump.org/wiki/show/HomePage

PIROL, Fachhochschule Osnabrück http://www.al.fh-osnabrueck.de/jump-download.html

PostGIS http://postgis.refractions.net/

PostgreSQL http://www.postgresql.org/


Source(s): OpenJUMP Tutorial

Unterstützen Sie
GISWiki !


 
Meine Werkzeuge
Namensräume
Varianten
Aktionen
Themen
Navigation
Werkzeuge